For all account questions and concerns, contact Customer Support.

Follow important game updates on Twitter @Pirate101 and @KI_Alerts, and Facebook!

connnection issues!

AuthorMessage
Captain
Apr 24, 2016
520
it is I, the dragonpirate, AKA fiery alyssa taylor AKA the one who stole your cookies earlier (LOL) with a bug report, regarding connection.

for the past few days, I have been experiencing very bad connection issues, about two per play session. I would get disconnected sometimes in the middle of a fight. like the terror-cotta warriors in moo tower or kane in the machine. its annoying. not sure if its my end, KI's end, or what. has anyone else been experiencing this?


Ensign
May 30, 2009
22
First bug that was found today was the ''Unable to Connect to Server. Try again later'' and ''Connection Lost!'' Messages when you're switching from a zone to another. It happens quite a lot and randomly too. not to mention the random server disconnects out of nowhere. And all of them didn't happen just to me, It happened to other people while we were talking at avery's court today.

A second one is where the Combat freezes and gives a long hang before advancing once ''Done'' is clicked. It takes from 30 seconds to 1 minute to advance it

A third one that i actually found is the Mojo Sparkler Staffy wand. It's supposed to be a Pure Staffy weapon for Witchdoctors but apparently it shows also that it has a shield. Which looks weird or makes no sense at all to see a Witchdoctor holding a Pure Staffy Mojo Sparkler weapon that has a shield as if it's a privateer weapon or something.

Another one that i'm not sure if it's a bug or not is, Emojis don't show in Private Text Chat Bubbles when you try to whisper a message an emoji to a friend. It doesn't show the Emoji at all while it shows only in the chat log box.

Ensign
Mar 02, 2013
1
im not sure if this is really a bug, but i guess it is? whenever i login, the game launches fine but when i try and play with one of my pirates, it says: "Unable to connect to server. Please try again later." sometimes im able to play but when i try and enter a new place it says that same message. pls help its triggering

Thanks in advance

Ensign
Jul 16, 2014
16
yeah i hate this bug causing problems in teleports and disconnections.

Petty Officer
Jan 09, 2010
67
Same last two days have only been able to log in once without getting this error, and as soon as I changed zones got it again :(

Petty Officer
Jan 09, 2010
67
It seems a lot of people are having this issue since the last release, including myself. I'm pretty sure that KI would know about it by now.

Ensign
Sep 02, 2014
2
Since the new update after loading the launcher in character selection, when i click on play it shows "Unable to connect to server.Try again later".For the new update i bought the member but now i can't even play it.Its been like this for 3 days now.I want KI to quickly solve so that my money don't get wasted.

Ensign
Sep 02, 2014
2
I am also having same problem.Submitted a ticket today, guess they will fix it soon.

Administrator
Hey all! I've merged these posts into one as they deal with the same issue. We have heard your pleas and are working on an update to fix this issue as soon as next week. Stay tuned for more information and sorry to hear about the troubles. We'll get it fixed.

*One-Eyed Jack, Your Pirate101 Community Manager*
Captain
Jun 10, 2013
723
One-Eyed Jack on Sep 29, 2017 wrote:
Hey all! I've merged these posts into one as they deal with the same issue. We have heard your pleas and are working on an update to fix this issue as soon as next week. Stay tuned for more information and sorry to hear about the troubles. We'll get it fixed.
When you update to fix these connection issues, can you please fix the recent curse word filter issue? It has come to my attention that 2 creative ways to type a curse word were recently blocked in open chat but somehow not blocked in text chat. This needs to be fixed ASAP.

Petty Officer
Jun 19, 2014
78
This has been happening to lots of people lately. Coincidentally, it started the day the update came out...

Admiral
Nov 01, 2013
1413
Wow! Welcome to the Message Boards, basically all of you!

Administrator
Hi all. Those of you who were experiencing this issue, can you please let us know if things are better today after this morning's update?

*One-Eyed Jack, Your Pirate101 Community Manager*
Captain
Apr 24, 2016
520
One-Eyed Jack on Oct 2, 2017 wrote:
Hi all. Those of you who were experiencing this issue, can you please let us know if things are better today after this morning's update?
its great! thanks for fixing it!

Ensign
Mar 25, 2017
1
thedragonpirate245... on Sep 17, 2017 wrote:
it is I, the dragonpirate, AKA fiery alyssa taylor AKA the one who stole your cookies earlier (LOL) with a bug report, regarding connection.

for the past few days, I have been experiencing very bad connection issues, about two per play session. I would get disconnected sometimes in the middle of a fight. like the terror-cotta warriors in moo tower or kane in the machine. its annoying. not sure if its my end, KI's end, or what. has anyone else been experiencing this?

Yea, please help I keep getting disconnected every 5 min and it's driving me insane please help.

Admiral
Nov 01, 2013
1413
ninjax364 on Oct 6, 2017 wrote:
Yea, please help I keep getting disconnected every 5 min and it's driving me insane please help.
Welcome to the Message Boards, Ninjax364! What I advise is you email support@KingsIsle.com for help.